// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)(?:Xander.*\bcar\b|\bcar\b.*Xander)").unwrap();
let string = "I’m looking for, but don’t know whether I am looking for “Xander’s car” ,“Xander got into the car”, “Xander leapt out of the way of the car”, or some other possibility.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}