using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"td>jo[^\'\""\\\/><]*? ";
string input = @"<td>John May lives </td><td> blablabla</td>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}