package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)td>jo[^\'\"\\\/><]*? `)
var str = `<td>John May lives </td><td> blablabla</td>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}