$re = '/(?=b(?!en)|(?<!b)en|e(?!n)|(?<!be)n|[^ben])(\w+)/i';
$str = 'Ben sits on a bench better end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);