re = /(?=b(?!en)|(?<!b)en|e(?!n)|(?<!be)n|[^ben])(\w+)/i
str = 'Ben sits on a bench better end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end