package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\d+e\+\d+\b`)
var str = `6[Sup. 1e+02]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}