$re = '/\b\d+e\+\d+\b/';
$str = '6[Sup. 1e+02]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);