using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:1-0-)+(.*?)\.htm";
string input = @"http://www.someurl.com/some-text-1-0-1-0-some-other-text.htm#id_76";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}