re = /(?:1-0-)+(.*?)\.htm/
str = 'http://www.someurl.com/some-text-1-0-1-0-some-other-text.htm#id_76'
# Print the match result
str.match(re) do |match|
puts match.to_s
end