package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\bz.p\b`)
var str = `Write a sentence with no zip and zap spaces:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}