package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A
\Q<?php\E
\s+
\Q?>\E
\Z`)
var str = `<?php
?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}