$re = '~\A
\Q<?php\E
\s+
\Q?>\E
\Z~x';
$str = '<?php
?>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);