$re = '/{(?\'bools\'.*?)}/m';
$str = '{True,True,False},{False,True,True},{False,True,True}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);