re = /{(?'bools'.*?)}/m
str = '{True,True,False},{False,True,True},{False,True,True}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end