#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$.+?(?=,|\s|\])(?:\](?=\]))?"
Local $sString = "['var1' => $var1, 'var2' => $obj->var1['asd']]" & @CRLF & _
"[ 'var1' => $var1, 'var2' => $obj->var1]" & @CRLF & _
"['var1' => $var1, 'var2' => $var2]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")