$re = '/\$.+?(?=,|\s|\])(?:\](?=\]))?/m';
$str = '[\'var1\' => $var1, \'var2\' => $obj->var1[\'asd\']]
[ \'var1\' => $var1, \'var2\' => $obj->var1]
[\'var1\' => $var1, \'var2\' => $var2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);