package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((([0-9A-Fa-f]{1,4}:){1,6}:)|(([0-9A-Fa-f]{1,4}:){7}))([0-9A-Fa-f]{1,4})$`)
var str = `FE80:0000:0000:0000:0202:B3FF::8329`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}