re = /^((([0-9A-Fa-f]{1,4}:){1,6}:)|(([0-9A-Fa-f]{1,4}:){7}))([0-9A-Fa-f]{1,4})$/
str = 'FE80:0000:0000:0000:0202:B3FF::8329'
# Print the match result
str.match(re) do |match|
puts match.to_s
end