import re
regex = re.compile(r"(.*(\([\d]+[^(].*\)|\(.*[^)][\d]+.*\)).*)", flags=re.MULTILINE)
test_str = ("hey(example1)\n"
"also(this(onetoo2(hard)))\n"
"but(here(is(a(harder)one)maybe23)Hehe)\n\n"
"this(one)is22misleading\n"
"how(to(go)on)with(multiple)3parent(heses(around))\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")