re = /(.*(\([\d]+[^(].*\)|\(.*[^)][\d]+.*\)).*)/m
str = 'hey(example1)
also(this(onetoo2(hard)))
but(here(is(a(harder)one)maybe23)Hehe)
this(one)is22misleading
how(to(go)on)with(multiple)3parent(heses(around))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end