package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b004010H2[127][02379](?:A[12])?\b`)
var str = `$str = "this is the code 004010H222A1 the rest is irrelevant";
$str = "the random number is 004010H223A2 ** anything else is irrelevant";
$str = "the last lottery number 004010H220A1 ~~ the rest is irrelevant";
$str = "yet another random sentence 004010H279A1 the rest is irrelevant";
$str = "any sentence before what i want 004010H279A1 the rest is irrelevant";
$str = "last winning number 004010H217~~~";
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}