#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-ZÀ-ž][\wÀ-ÿ]+"
Local $sString = "é è ô" & @CRLF & _
"" & @CRLF & _
"1 2 3" & @CRLF & _
"" & @CRLF & _
"a b c" & @CRLF & _
"Département" & @CRLF & _
", . \ | / ?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")