const regex = /[a-zA-ZÀ-ž][\wÀ-ÿ]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-ZÀ-ž][\\wÀ-ÿ]+', '')
const str = `é è ô
1 2 3
a b c
Département
, . \\ | / ?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}