package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(snapshots\/[^\/]+)$`)
var str = `/subscriptions/5522233222-d762-666e-555a-e6666666666/resourcegroups/rg-sql-Belguim-01/providers/Microsoft.Compute/snapshots/vm-sql-image-v3.3-pre-sysprep-Oct-2021-BG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}