re = /(snapshots\/[^\/]+)$/m
str = '/subscriptions/5522233222-d762-666e-555a-e6666666666/resourcegroups/rg-sql-Belguim-01/providers/Microsoft.Compute/snapshots/vm-sql-image-v3.3-pre-sysprep-Oct-2021-BG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end