using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<!\S)(?!\s)(?:m|\b)(?:a|\b)(?:x|\b)(?:m|\b)(?:u|\b)(?:s|\b)(?:t|\b)(?:e|\b)(?:r|\b)(?:m|\b)(?:a|\b)(?:n|\b)(?:n|\b)(?:\s+(?!\s)(?:m|\b)(?:a|\b)(?:x|\b)(?:m|\b)(?:u|\b)(?:s|\b)(?:t|\b)(?:e|\b)(?:r|\b)(?:m|\b)(?:a|\b)(?:n|\b)(?:n|\b))*(?!\S)";
string input = @"orem ipsum dolor sit amet, consectetur max adipiscing elit. Proin maxm pellentesque dui maxmustermann eu erat mustermann rhoncus tempor sit amet quis odio. Max Mustermann habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Max Muster Mann et malesuada fames ac ante ipsum primis in faucibus. Nam vitae nisl d";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}