const regex = /(?i)(?<!\S)(?!\s)(?:m|\b)(?:a|\b)(?:x|\b)(?:m|\b)(?:u|\b)(?:s|\b)(?:t|\b)(?:e|\b)(?:r|\b)(?:m|\b)(?:a|\b)(?:n|\b)(?:n|\b)(?:\s+(?!\s)(?:m|\b)(?:a|\b)(?:x|\b)(?:m|\b)(?:u|\b)(?:s|\b)(?:t|\b)(?:e|\b)(?:r|\b)(?:m|\b)(?:a|\b)(?:n|\b)(?:n|\b))*(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<!\\S)(?!\\s)(?:m|\\b)(?:a|\\b)(?:x|\\b)(?:m|\\b)(?:u|\\b)(?:s|\\b)(?:t|\\b)(?:e|\\b)(?:r|\\b)(?:m|\\b)(?:a|\\b)(?:n|\\b)(?:n|\\b)(?:\\s+(?!\\s)(?:m|\\b)(?:a|\\b)(?:x|\\b)(?:m|\\b)(?:u|\\b)(?:s|\\b)(?:t|\\b)(?:e|\\b)(?:r|\\b)(?:m|\\b)(?:a|\\b)(?:n|\\b)(?:n|\\b))*(?!\\S)', 'g')
const str = `orem ipsum dolor sit amet, consectetur max adipiscing elit. Proin maxm pellentesque dui maxmustermann eu erat mustermann rhoncus tempor sit amet quis odio. Max Mustermann habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Max Muster Mann et malesuada fames ac ante ipsum primis in faucibus. Nam vitae nisl d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}