re = /(?<name>\w+)\((?<content>(.*|(\R)).*)\)/m
str = 'sin0+sin90+sin(90+sin(sin(sin())))+sin(0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end