$re = '~/[^/]*(?=/[^/]*$)~m';
$str = 'https://fbcdn-creative-a.akamaihd.net/hads-ak-xaf1/t45.1600-4/s110x80/10156615_6017073002888_1171145694_n.png';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;