import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.{1,254}$)(^(?>(?!\\d+\\.)[a-zA-Z0-9_\\-]{1,63}\\.?)+(?:[a-zA-Z]{2,})$)";
final String string = "Match:\n"
+ "host.domain.com\n"
+ "_host.domain.com\n"
+ "1host-2._ldap.domain.com\n\n"
+ "Non-Matches:\n"
+ "33.domain.com\n"
+ "host..com\n"
+ "this_really_long._fully_qualified_domain_name._contains_257_characters_w\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}