package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(lang_[^;]*?);`)
var str = `<?php echo lang_xxxx; ?>
<?php echo lang_es; ?>`
var substitution = "$lang['$1'];"
fmt.Println(re.ReplaceAllString(str, substitution))
}