const regex = /(lang_[^;]*?);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(lang_[^;]*?);', 'g')
const str = `<?php echo lang_xxxx; ?>
<?php echo lang_es; ?>`;
const subst = `$lang['$1'];`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);