re = /(\/\w{30,})(?:.+?\1){3,}?/
str = 'http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end