import Foundation
let pattern = #"(\/\w{30,})(?:.+?\1){3,}?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
http://www.flashprofession.com/act/bcaip86eJR2W5hKmMjFiKVWmKyLjmiMKhkOm0Mjh906/moreblah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}