package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^.]|\.{2,})+\.`)
var str = `Quisiera yo detectar los puntos... pero solo los puntos aislados. Los puntos suspensivos no los quiero detectar. A eso me refiero.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}