re = /(?:[^.]|\.{2,})+\./m
str = 'Quisiera yo detectar los puntos... pero solo los puntos aislados. Los puntos suspensivos no los quiero detectar. A eso me refiero.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end