using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9]+\s*([a-zA-Z]+\s*[a-zA-Z]+\s)*[0-9]*";
string input = @" 7850 S Dean Martin Dr Ste 505";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}