package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+\s*([a-zA-Z]+\s*[a-zA-Z]+\s)*[0-9]*`)
var str = ` 7850 S Dean Martin Dr Ste 505`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}