const regex = /\b[0-9.]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[0-9.]+\\b', 'gm')
const str = `=d3456-123123.12"def\\"12.39.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}