$re = '/\b[0-9.]+\b/m';
$str = '=d3456-123123.12"def\\"12.39.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);