$re = '/(?!addressAdd|streetnr)(?:street|addr|straße|strasse|adr)/';
$str = 'addressAdd streetnr street addr straße strasse adr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);