re = /(?!addressAdd|streetnr)(?:street|addr|straße|strasse|adr)/
str = 'addressAdd streetnr street addr straße strasse adr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end