$re = '/^(?=0+[1-9])0\d{5}$/m';
$str = '000123
002535
000000
2654
123456
0123456
000021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);