re = /^(?=0+[1-9])0\d{5}$/m
str = '000123
002535
000000
2654
123456
0123456
000021'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end