package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/.*\.[\w:]+`)
var str = `In file included from /some/directoy/3.33A.37.2/something else/dogs.txt,
from /some/directoy/something else/dogs.txt,
from /some/directoyr/3.33A.37.2/something else/dogs.txt,
from /var/log/xyz/10032008.log,
from /var/log/xyz/test.c:29:
Solution:
please the file something.h has to be alone without others include, it has to be present in release letter,
in order to be included in /var/log/xyz/test.c automatically
Other Note:
The file something.c must contain the somethinge.h and not the ecpfmbsd.h because it doesn't contain C operative code.. everything good..
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}