# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/.*\.[\w:]+"
test_str = ("In file included from /some/directoy/3.33A.37.2/something else/dogs.txt,\n"
" from /some/directoy/something else/dogs.txt,\n"
" from /some/directoyr/3.33A.37.2/something else/dogs.txt,\n"
" from /var/log/xyz/10032008.log,\n"
" from /var/log/xyz/test.c:29:\n"
"Solution:\n"
"please the file something.h has to be alone without others include, it has to be present in release letter, \n"
"in order to be included in /var/log/xyz/test.c automatically\n"
"Other Note: \n"
"The file something.c must contain the somethinge.h and not the ecpfmbsd.h because it doesn't contain C operative code.. everything good.. \n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.