const regex = /^(((((0[1-9])|(1\d)|(2[0-8]))\/((0[1-9])|(1[0-2])))|((31\/((0[13578])|(1[02])))|((29|30)\/((0[1,3-9])|(1[0-2])))))\/(\d{4}))|((29\/02\/(\d{2})(([02468][048])|([13579][26]))))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((((0[1-9])|(1\\d)|(2[0-8]))\\\/((0[1-9])|(1[0-2])))|((31\\\/((0[13578])|(1[02])))|((29|30)\\\/((0[1,3-9])|(1[0-2])))))\\\/(\\d{4}))|((29\\\/02\\\/(\\d{2})(([02468][048])|([13579][26]))))$', 'g')
const str = `29/02/2016
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}