import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([01]\\d|2[0123])):([0-5][0-9])$";
final String string = "00:00\n"
+ "00:01\n"
+ "01:00\n"
+ "03:33\n"
+ "09:09\n"
+ "10:10\n"
+ "19:45\n"
+ "20:43\n"
+ "23:59\n\n"
+ "213:56\n"
+ "23:60\n"
+ "23:99\n"
+ "24:00\n"
+ "29:00\n"
+ "99:00\n"
+ "99:99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}