const regex = /^(([01]\d|2[0123])):([0-5][0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([01]\\d|2[0123])):([0-5][0-9])$', 'gm')
const str = `00:00
00:01
01:00
03:33
09:09
10:10
19:45
20:43
23:59
213:56
23:60
23:99
24:00
29:00
99:00
99:99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}