import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:\\/etc\\/default|\\/man8)\\/useradd(?!.*useradd)).*useradd";
final String string = "## no match\n"
+ "cat /etc/default/useradd \n"
+ "less /usr/share/man/ja/man8/useradd.8.gz\n"
+ "## match:\n"
+ "useradd evil\n"
+ "/usr/sbin/useradd\n"
+ "cat /etc/default/useradd; useradd evil\n"
+ "cat /etc/default/useradd; /usr/sbin/useradd evil\n"
+ "cat /etc/default/useradd; cd /usr/lib/; ../sbin/useradd evil";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}